WordPress actualizará instalaciones antiguas INEVITABLE

Si tienes una web con una versión desactualizada de WordPress, entonces tienes muchas vulneravilidades y el equipo que da soporte a WordPress planea evitarlo.

Los motivos por los cuales mucha gente no actualiza su WordPress son varios, por ejemplo:

  • El tema que usa no es compatible con la última versión de WordPress, o el administrador no sabe si es compatible o no, por lo que prefiere no arriesgarse.
  • La base de datos es tan grande y tan antigua que hay miedo de que con la actualización automática se estropeé algo. Al ejecutarse el script de actualización de la base de datos pueden ocurrir problemas de diversos tipos, desde los generados por instalaciones de plugins a problemas con el servicio de hosting en el momento del upgrade, ya que se requieren más recursos de lo normal.
  • – Los backups no se generan en tiempo real, y eso genera una inseguridad enorme a la hora de realizar grandes cambios en una web.

WordPress tiene en un plan para actualizar automáticamente por la fuerza versiones anteriores instaladas. Las versiones despúes de la versión a la 4.7, quedarán intactas.

El equipo de WordPress dijo que planea monitorear este proceso en busca de errores y sitios que dejen de funcionar, de forma que si se detecta algo que ocasiones fallas en miles de sitios, pararán las actualizaciones automáticas.

Si solo se dañan unos pocos sitios individuales, esos sitios se revertirán a sus versiones anteriores y se notificará al propietario por correo electrónico.

WordPress planea permitir que los propietarios elijan si desean desistir a la actualización forzada, y enviará correos electrónicos a los administradores del sitio web y mostrará una advertencia severa en los paneles de los sitios web antes de comenzar el proceso de actualización automática.

Las versiones anteriores a la v3.7 no se actualizarán automáticamente porque la v3.7 es la versión en la que se incluyó el mecanismo de actualización automática en el CMS. Estas versiones anteriores solo admiten actualizaciones manuales y no se pueden actualizar automáticamente. Sin embargo, las versiones anteriores a la v3.7 representan menos del 1% de todas las instalaciones de WordPress, por lo que esto no será un gran problema.

Todo sea por una web segura.

Publicado por